Apache HTTP Server 2.2.19 x86 and x64 Windows Installers

Apache logo

It has been hardly three days since I posted Apache 2.2.18 binaries and Apache 2.2.19 has already been released. It was released yesterday, that is May 22, 2011 and has a few bug and security fixes.

Here are the 32 and 64 bit binaries. They were compiled with Visual C++ 2008 (VC9) and the installers are digitally signed. Please make sure that the digital signatures are valid before installing.

Download

apache_2.2.19-x64-no-ssl.msi

apache_2.2.19-x64-openssl-1.0.0d.msi

apache_2.2.19-x86-no-ssl.msi

apache_2.2.19-x86-openssl-1.0.0d.msi

I mentioned in my previous post that I would be releasing the next version of Apache sooner, since I compiled and posted Apache 2.2.18 seven days after its release. Although I am posting 2.2.19 a day after its release, it seems I wasn’t quick enough since I already received a few reminders from some of you that 2.2.19 was out. I will try to post the next version of Apache the same day it’s released. πŸ˜€

Related Posts:

Next Post:
Previous Post:

11 Comments

  1. bagu

    Hello,

    As ICE 3.4.2 is release, can you compile ice_php.dll for apache + php 5.3.6 x86 VC9 ?
    Thanks a lot.

  2. HisGadget

    Why i’m always failed every time i tried to download it?

  3. Marcus

    Thanks for VC9 installer version!

  4. Anindya

    @bagu

    Hi. Sorry for the late reply. I hope that by now you have found the php_ice.dll extension for PHP 5.3.6 x64 x86 VC9 which is included in the Ice 3.4.2 installer.

    @Marcus

    You’re welcome. πŸ™‚

  5. Saravji

    Hey Anindya,

    first: thanks for the 64 bit versions. Greatly appreciated.
    Question: Do you also / would it make to also compile mod_jk in 64 bit?
    It is only coming in 32 bit, and I cannot use the 32 bit mod on a 64 bit server. πŸ™

  6. Anindya

    Hi. I will try to compile it this weekend. But there is an older version available here.

  7. Saravji

    Thanks. That’s the one I am currently using. I just thought it might be a good idea for you to have it all in one place. πŸ˜‰ I am still pretty new to this (or again new to this, after I paused since 2001) and am setting up an apache / tomcat / membase / mysql constellation.

  8. hugo

    thanks for the x64 vers

    sir im a bit n00b on this so mind the question
    is this file stable?

  9. AbuM@lek

    Hi,
    Please, how can we make sure that the digital signatures are valid before installing.
    Thank you

  10. zmcjs

    apache 2.2.20 and php 5.3.8 is release!
    paease!please!

  11. Murali

    Hi, where i can get mod_wl_22.so for windows 64 bit os…please suggest download link….

Leave a Reply to AbuM@lek

Notify me of follow-up comments via e-mail.