Apache HTTP Server 2.4.1 x86 and x64 Windows Installers

Apache

Apache HTTP Server 2.4.1 was released on February 21, 2012. This version is a major release and includes many new features. There are also some configuration changes, so if you would like to upgrade to version 2.4, you should first read the upgrade documentation.

The following binaries were compiled with Visual C++ 2008 (VC9) against apr 1.4.6, apr-util 1.4.1, apr-iconv 1.2.1, expat 2.0.1, libxml2 2.7.8, lua 5.1.4, OpenSSL 1.0.0g, pcre 8.30 and zlib 1.2.6. IPv6 support has also been enabled. The installers are once again digitally signed, so you can simply check the digital signatures to verify the integrity of the installers. I have also provided the file hashes for those who want to use them instead.

Download

apache_2.4.1-x64-openssl-1.0.0g.msi (Mirror 1) (Mirror 2)

CRC32: 7678BE2F
MD5: 854DD980AADDC77EDB719D22AB584014
SHA-1: DD5B470344F1CE935EEA5A713609D13B91561344

apache_2.4.1-x64-no-ssl.msi (Mirror 1) (Mirror 2)

CRC32: BF0F1617
MD5: 4CF5CE8BF75086B0DA53E93BFF8293D4
SHA-1: C70485C022F74B68BCB66D3EB5BA434E29959EC6

apache_2.4.1-x86-no-ssl.msi (Mirror 1) (Mirror 2)

CRC32: 784A5E10
MD5: C8254720CF648E4F78BD25BE6F41492B
SHA-1: AD2093AD6B87F8F787C50E6A5862E6E315404DD0

apache_2.4.1-x86-openssl-1.0.0g.msi (Mirror 1) (Mirror 2)

CRC32: 653A3014
MD5: D9EBB58DF7582A219FCC11CE09917379
SHA-1: 2F9DDD06AB66BC218B9ECD7A6EAF5D871E70B3F0


Related Posts:

Next Post:
Previous Post:

16 Comments

  1. dioskey

    GREAT! ;D

    Only one thing… why you distribute only installation packages?
    If one need only to update there is no need to reinstalla the package or am i wrong?

    Just another thing, the php5apache2_4.dll that you distribute can be seen as a security risk by Symantec Endpoint Protection maybe becouse is a direct dll download. :)

    Thanks in advance!

  2. Marko

    Thanks!

  3. Geen

    Many thanks!!!

  4. Otomatic

    Thanks,

    Without installer, just a zip file, is it possible ?
    And, at the same time, a 64bit version of PHP 5.4.0…

    The user becomes more demanding, it is given more and more he wants!

  5. J o n a

    Hi there,

    What do you think about this:
    http://sourceforge.net/projects/mod-security/

    It would be nice if it could be in the package.

    Thanks.

    I will try this.

  6. Sampath

    I need a 64 bit PHP version that is compatible with this version of apache server, 2.4.1 X64. Can you help build this please?

  7. Otomatic

    Hello,
    Please, PHP 5.4.0 64-bit would make me happy.

  8. kdn1990

    not work with PHP 5.3.10 x64 windows 7

  9. Conor Duffy

    @kdn1990 – It does work with PHP 5.3.10 x64 on Windows 7 x64, I’m using it right now!

    http://dl.dropbox.com/u/39034750/phpinfo.htm

  10. Anindya

    @dioskey

    If you had previously installed Apache using an installer, then its better to uninstall the old version first. Then you have the choice of either installing the new version using an installer or a zip archive. If you prefer zip archives, you can use the ones available at Apache Lounge – http://www.apachelounge.com/download/.

    @Marko and @Geen

    You’re welcome! :D

    @Otomatic

    64 bit PHP 5.4.0 is available now – http://www.anindya.com/php-5-4-0-x64-64-bit-for-windows/.

    @J o n a

    Will compile and post mod_security soon.

    @Sampath

    I hope you found this post by now.

    The 64 bit PHP 5.4.0 that I posted today is also compatible with this version of Apache.

  11. Neil

    Love your work, thanks. Any chance of a set of mod_jk.so connectors for 2.4.1 64 bit? Thanks

  12. zmcjs

    apache 2.4.2 is release please modfily x86 and x64 installer packages!
    thank you very much!

  13. zmcjs

    Apache httpd 2.4.2 Released

  14. ryan

    You mind explaining your recipe to build this product?

  15. Diana

    Do you have an MSI installer for 2.4.3?

    Thanks!

  16. Anindya

    @ryan

    Thinking about posting a tutorial soon.

    @Diana

    Sorry for the reply reply. MSI installers for 2.4.3 will be available very soon.

Leave a Comment

Notify me of follow-up comments via e-mail.